Scheduled for November 21, 2025 at 3:24 AM – 7:58 AM
Affects
QRPH API
Under maintenance from 3:24 AM to 7:58 AM
Completed
November 21, 2025 at 7:58 AMCompleted
November 21, 2025 at 7:58 AMThe service disruption has been resolved.
In progress
November 21, 2025 at 3:24 AMIn progress
November 21, 2025 at 3:24 AMThis service disruption is currently ongoing.
Planned
November 21, 2025 at 3:24 AMPlanned
November 21, 2025 at 3:24 AMDear Partners,
We would like to inform you of an ongoing service disruption affecting G-XCHANGE, INC. (GCash) as follows:
During this period, the following GCash services may be temporarily unavailable or experience delays:
Buy Load
Pay Bills
Payment via QRPH
Bank Transfer
Express Send
Our team is actively monitoring the situation, and services are currently being restored by GCash. We will provide another update within the next hour.
If you have any questions or concerns, please feel free to reach out to our support team. Thank you for your understanding.
Sources:
https://www.facebook.com/share/p/1D6tagbuHq/
https://help.gcash.com/hc/en-us/sections/22717320336281-GCash-Advisories