Scheduled for February 23, 2026 at 5:00 PM – 8:00 PM
Affects
QRPH API
Under maintenance from 5:00 PM to 8:00 PM
Completed
February 23, 2026 at 8:00 PMCompleted
February 23, 2026 at 8:00 PMThis scheduled maintenance has been completed successfully.
In progress
February 23, 2026 at 5:00 PMIn progress
February 23, 2026 at 5:00 PMThis scheduled maintenance is now in progress.
Planned
February 23, 2026 at 5:00 PMPlanned
February 23, 2026 at 5:00 PMDear Partners,
We would like to inform you of a scheduled system maintenance activity affecting Maya Philippines and Maya Bank as follows:
During this maintenance period, InstaPay sending and receiving transactions involving Maya Philippines and Maya Bank accounts may temporarily fail or experience interruptions.
We recommend scheduling your transactions outside this period to avoid any interruptions.
Thank you for your continued support and understanding. If you have any questions or concerns, please feel free to reach out to our support team.