Modulus Labs - Partner Incident Issue – Incident details

Partner Incident Issue

Resolved
Operational
Started 6 months agoLasted about 13 hours

Affected

QRPH API

Operational from 2:55 AM to 4:00 PM

Updates
  • Resolved
    Resolved

    Dear Partners,

    We’re pleased to inform you that the issue affecting QRPH payments has been successfully resolved.

    We have resumed normal operations and are continuing to monitor the system closely to ensure ongoing stability.

    Thank you for your patience and cooperation throughout the incident.

  • Update
    Update

    Dear Partners,

    In light of the current issue, we are recommending advising your merchants to temporarily hold off on using the QRPH payments until the matter is fully investigated and resolved.

    Our team is actively investigating and will provide updates as soon as more information becomes available. We’ll notify you immediately once the issue has been addressed and the service is stable again.

    Thank you for your understanding and support.

  • Investigating
    Investigating

    Dear Partners,

    We are currently monitoring an unusual number of transactions being stuck in a pending status. Our Incident Response Team is already on a call and actively looking into the situation.

    We’ll keep you updated as we learn more and will follow up once we have a clearer understanding of the potential issue and next steps.

    Thanks for your patience.